Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE » RADICORE Installation Issues » V 2.19.0 - include_path
V 2.19.0 - include_path [message #7610] Mon, 02 August 2021 10:37 Go to next message
htManager is currently offline  htManager
Messages: 339
Registered: May 2014
Senior Member
Hi Toni,

after installing V 2.19.0 I get the following error when calling logon.php:

Fatal error: require(): Failed opening required 'include.general.inc' (include_path='.:/usr/local/lib/php:/home/radicore/includes' ) in C:\xampp\htdocs\radicore\menu\logon.php on line 28

The include_path in my php.ini directs to the correct directory. What can I do?

Best regards,

Juergen
Re: V 2.19.0 - include_path [message #7611 is a reply to message #7610] Mon, 02 August 2021 11:39 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2272
Registered: April 2006
Location: Surrey, UK
Senior Member
What is the correct directory? If that directory is not shown in the error message then that directory is not being searched. Do you have an htaccess file which modifies the includes_path?

Re: V 2.19.0 - include_path [message #7612 is a reply to message #7611] Mon, 02 August 2021 11:59 Go to previous messageGo to next message
htManager is currently offline  htManager
Messages: 339
Registered: May 2014
Senior Member
I only copied all the files of V 2.19.0 in my directory.

I attached a screen shot of the phpinfo.php of the include_path.
Re: V 2.19.0 - include_path [message #7613 is a reply to message #7612] Mon, 02 August 2021 12:42 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2272
Registered: April 2006
Location: Surrey, UK
Senior Member
You haven't answered the question "What is the correct directory?" If this directory is not in the include_path then that is your problem.

Re: V 2.19.0 - include_path [message #7614 is a reply to message #7613] Mon, 02 August 2021 16:02 Go to previous messageGo to next message
htManager is currently offline  htManager
Messages: 339
Registered: May 2014
Senior Member
The correct directory is c:\xampp\htdocs\radicore\includes.

It is shown in the column master value of the directive include_path in the phpinfo.php, separated by semi-colons.
Re: V 2.19.0 - include_path [message #7615 is a reply to message #7613] Mon, 02 August 2021 16:21 Go to previous messageGo to next message
htManager is currently offline  htManager
Messages: 339
Registered: May 2014
Senior Member
It was the .htaccess file. I copied the file coming with the new version V 2.19.0 and this caused the problems. When I change the include_path in this .htaccess file everything works fine again.
Re: V 2.19.0 - include_path [message #7616 is a reply to message #7614] Tue, 03 August 2021 04:16 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2272
Registered: April 2006
Location: Surrey, UK
Senior Member
You should have noticed that the error message did not show the correct directory in its include_path, and this should have given you a clue that the default setting in your php.ini file was being altered at runtime.

Re: V 2.19.0 - include_path [message #7617 is a reply to message #7616] Tue, 03 August 2021 04:17 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2272
Registered: April 2006
Location: Surrey, UK
Senior Member
Whoops! I will try to remove that from future releases.

Re: V 2.19.0 - include_path [message #7641 is a reply to message #7610] Tue, 17 August 2021 03:35 Go to previous messageGo to next message
shoaibleghari is currently offline  shoaibleghari
Messages: 4
Registered: August 2021
Junior Member
I've configured radicore with the following setting. I am a window user.

PHP 5 and above and Apache version 2.4

1 => Include path in htacess file. My xampp in installed on D drive
php_value include_path ".;D:\xampp\htdocs\radicore\includes"

2=> changing in php ini file. The include path in htacess and php ini files must be the same.
include_path = ".;D\xampp\htdocs\radicore\includes"

3=> changing in httpd.conf file
<Files "htaccess.txt">
Require all denied
</Files>

and

<Directory "D:/Apache2/htdocs">
AllowOverride All
Require all granted
</Directory>

Also uncomment xsl extension in php ini file.
Re: V 2.19.0 - include_path [message #7642 is a reply to message #7617] Tue, 17 August 2021 03:57 Go to previous messageGo to next message
shoaibleghari is currently offline  shoaibleghari
Messages: 4
Registered: August 2021
Junior Member
for window user and php version greater than or equal to 5 and apache 2
path in htacess file
php_value include_path ".;C:\xampp\htdocs\radicore\includes"
path in php ini file
include_path = ".;C:\xampp\htdocs\radicore\includes"

copy and paste the provided files and directory lines under apache2 in httpd.conf file.

uncomment xsl extension in php ini file.

that's all.
Re: V 2.19.0 - include_path [message #7643 is a reply to message #7642] Tue, 17 August 2021 04:32 Go to previous message
AJM is currently offline  AJM
Messages: 2272
Registered: April 2006
Location: Surrey, UK
Senior Member
It's amazing how easily it works when you follow the instructions.

Previous Topic: V 2.17.0 - dml.mysqili.class.inc
Next Topic: Installation issue
Goto Forum:
  


Current Time: Tue Oct 19 20:51:36 EDT 2021

Total time taken to generate the page: 0.01512 seconds