Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE » RADICORE Installation Issues » Apache error (php5ts.dll and # 256)
Apache error [message #2635] Mon, 20 December 2010 18:18 Go to next message
lgabrielse is currently offline  lgabrielse
Messages: 5
Registered: December 2010
Location: Florida, USA
Junior Member
Hi,
I am evaluating Radicore to write a Medical Hospital/Laboratory/Pharmacy information system for mission hospitals or clinics. I am familiar with writing web pages using VB Script and ASP, so OOP and php are new to me.

I got interested because of the role based security.
I installed the php and mysql and radicore and read a lot of the published information. I worked through the tutorial until I tried "2.2 Select Transaction Pattern" and I am stuck.


Apache Server Error

szAppName : httpd.exe szAppVer : 2.2.11.0 szModName : php5ts.dll
szModVer : 5.3.0.0 offset : 0000b4e3


Apache Error log:
Parent: child process exited with status 3221225477 -- Restarting


I presume this has to do with adding a record to the db, so I went to see if I could add a new user. When I tried that, I got a error screen (below): (but the record was saved in the the db)
Is there a place to look up error messages like # 256?

The following has been reported to the administrator:
2010-12-20 23:02:00

Fatal Error: mnu_favourite(add4) - Task 'mnu_favourite(add4)' does not exist. (# 256).

Error in line 1814 of file 'C:\wamp\www\radicore\includes\include.session.inc'.

PHP_SELF: /radicore/menu/mnu_user(add1).php

CURRENT DIRECTORY: C:\wamp\www\radicore\menu

SERVER_ADDR: 127.0.0.1

SERVER_NAME: localhost

HTTP_HOST: localhost

User Id: LEN

REMOTE_ADDR: 127.0.0.1

REQUEST_URI: /radicore/menu/mnu_user(add1).php


I googled for some solutions, but nothing seems to fix this apache error.


Any help would be appreciated,
Len Gabrielse


Len
Re: Apache error [message #2636 is a reply to message #2635] Tue, 21 December 2010 02:57 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2312
Registered: April 2006
Location: Surrey, UK
Senior Member
The Apache error is probably caused by a faulty installation.

The error concerning 'mnu_favourite(add4)' was caused by the fact that the menu_data.sql file was not up to date, so I have attached a new version.
  • Attachment: menu-data.zip
    (Size: 33.23KB, Downloaded 895 times)


Re: Apache error [message #2637 is a reply to message #2636] Tue, 21 December 2010 08:24 Go to previous messageGo to next message
lgabrielse is currently offline  lgabrielse
Messages: 5
Registered: December 2010
Location: Florida, USA
Junior Member
Thank You for your prompt reply.

Which WAMP package would you recommend if I reinstall everything?

I can use a Win XP or Win 7 machine. Win 7 can use 32bit or 64 bit. Any recommendations?

Do you know if anyone has already written a Lab or medical information system with Radicore?

Your help is appreciated, Len


Len
Re: Apache error [message #2638 is a reply to message #2635] Tue, 21 December 2010 18:50 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2312
Registered: April 2006
Location: Surrey, UK
Senior Member
I don't use any all-in-one WAMP package as I prefer to install every item individually.

Users of Radicore rarely inform me of the type of applications that they write, so I cannot tell if anyone has written a medical information system.


Re: Apache error [message #2660 is a reply to message #2638] Thu, 20 January 2011 10:31 Go to previous messageGo to next message
lgabrielse is currently offline  lgabrielse
Messages: 5
Registered: December 2010
Location: Florida, USA
Junior Member
Well, I reinstalled everything, recreated the tables, etc, reviewed the installation instructions carefully, googled the apache error, tried the suggested solutions, and spent way too many hours trying to get past this same problem adding a pattern, so I guess I have to give up!
I would need a better support system to make this work for me.

Len


Len
Re: Apache error [message #2661 is a reply to message #2660] Thu, 20 January 2011 11:19 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2312
Registered: April 2006
Location: Surrey, UK
Senior Member
Which version of PHP are you using - 5.2 or 5.3? I haven't done any testing on 5.3 yet as Zend Studio does not have a debugger which works with PHP when it is run as an Apache module. They will only support the FastCGI version, but it is so unreliable that I cannot use it. Try installing PHP version 5.2 and see if that works.

Re: Apache error [message #2662 is a reply to message #2661] Mon, 24 January 2011 15:29 Go to previous messageGo to next message
lgabrielse is currently offline  lgabrielse
Messages: 5
Registered: December 2010
Location: Florida, USA
Junior Member
Thanks for the tip. I installed PHP 5.2.11 (instead of PHP 5.3.3) and now adding a pattern works!! BTW, I am using WAMP2, with Apache 2.2.17 and MySQL 5.5.8 on windows XP machine. Please let me know if there is a more reliable configuration.
As a PHP and OO newbie, I am finding it difficult to learn this system.

Len


Len
Re: Apache error [message #2663 is a reply to message #2662] Mon, 24 January 2011 15:45 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2312
Registered: April 2006
Location: Surrey, UK
Senior Member
I don't use any all-in-one installers like WAMP as several people have reported problems with them in the past. At least you have got RADICORE working now, so you can work your way through the tutorial.

I must warn you that if you are new to both OO and PHP then you could find RADICORE a bit too advanced, but hopefully the documentation and inline comments should help you understand it a bit better.


Re: Apache error [message #2670 is a reply to message #2635] Tue, 15 February 2011 03:25 Go to previous messageGo to next message
parkin11 is currently offline  parkin11
Messages: 2
Registered: February 2011
Junior Member
I am pretty sure that the problem may be related to improper installation. Today I had a very close look at the error messages and reached this conclusion. To be 100% sure I sought the help of a friend of mine who also agreed with me. I would request lgabrielse to install it once again. I am sure that it will solve the issue.

"ALL IS WELL"
Re: Apache error [message #2674 is a reply to message #2670] Tue, 15 February 2011 08:35 Go to previous messageGo to next message
lgabrielse is currently offline  lgabrielse
Messages: 5
Registered: December 2010
Location: Florida, USA
Junior Member
Thanks for your response. As I indicated on Jan 24, it works OK with PHP 5.2 but not with 5.3.3. (A good learning experience, if nothing else.)

Len
Re: Apache error [message #2675 is a reply to message #2674] Tue, 15 February 2011 13:44 Go to previous message
AJM is currently offline  AJM
Messages: 2312
Registered: April 2006
Location: Surrey, UK
Senior Member
I have not yet tried to run Radicore under PHP 5.3 as Zend, the makers of Zend Studio, refuse to release a debug dll which works with PHP when run as an apache module. They will only support the fastcgi version, which I have tried and found to be total cr*p. Until I can find another IDE with a proper debugger I can only support PHP 5.2.

Previous Topic: logon error
Next Topic: Making the classroom example work
Goto Forum:
  


Current Time: Sun Jan 29 06:46:02 EST 2023

Total time taken to generate the page: 0.01572 seconds