Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE » RADICORE Installation Issues » eregi(): REG_BADRPT (# 256)
eregi(): REG_BADRPT (# 256) [message #283] Wed, 20 September 2006 21:02 Go to next message
haribole is currently offline  haribole
Messages: 7
Registered: July 2006
Location: Cary
Junior Member
Wonder what this could be due to:

I am using this on debian sarge, standard install.

Fatal Error: eregi(): REG_BADRPT (# 256).

Error in line 47 of file '/var/www/radicore/includes/dml.mysql.class.inc'.

Script: /radicore/menu/logon.php

Remote Address: 192.168.43.1

Request URI: /radicore/menu/logon.php

Page Stack:

Thanks
Hari
Re: eregi(): REG_BADRPT (# 256) [message #285 is a reply to message #283] Thu, 21 September 2006 05:38 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
Strange. That code works without problem on both of my local PC's as well as my hosted server. The code in question is actually on line 125 and should look as follows:
if (!empty($dbprefix)) {
    if (!eregi('^(' .$dbprefix .')', $dbname)) {
        // prefix may be different on different servers
        $dbname = $dbprefix .$dbname;
    } // if
} // if

Either you have a corrupt version of file dml.mysql.class.inc or you have something wrong with your PHP installation.

BTW, what value are you passing in for $dbprefix (from your config.inc file)?


Re: eregi(): REG_BADRPT (# 256) [message #287 is a reply to message #285] Thu, 21 September 2006 05:55 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
The error REG_BADRPT actually means "Invalid use of repetition operators such as using '*' as the first character."

This sounds suspiciously like you left the following line in your config.inc file:
$GLOBALS['dbprefix']   = '****';

You need to edit that line to define the actual prefix, or set it to '' if there isn't one.


Re: eregi(): REG_BADRPT (# 256) [message #288 is a reply to message #287] Thu, 21 September 2006 08:46 Go to previous messageGo to next message
haribole is currently offline  haribole
Messages: 7
Registered: July 2006
Location: Cary
Junior Member
Thanks!!

That fixed it

Tony, you are awesome.
Re: eregi(): REG_BADRPT (# 256) [message #289 is a reply to message #288] Thu, 21 September 2006 09:05 Go to previous message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
I hope you meant "awesome" and not "awful" Smile

Previous Topic: Install all tables in one DB
Next Topic: Install Problem
Goto Forum:
  


Current Time: Mon Jun 24 10:01:13 EDT 2024

Total time taken to generate the page: 0.01530 seconds