Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE development » Transaction Patterns » POPUP3 not working
POPUP3 not working [message #7568] Mon, 25 January 2021 04:04 Go to next message
htManager is currently offline  htManager
Messages: 339
Registered: May 2014
Senior Member
After calling the PopUp3 pattern and after choosing an occurence there is no reaction in the _cm_popupReturn() method. Only the choose null option is handled. Is this correct or do I have to do something else?
Re: POPUP3 not working [message #7569 is a reply to message #7568] Mon, 25 January 2021 04:23 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2272
Registered: April 2006
Location: Surrey, UK
Senior Member
It works as advertised on my PC. Can you step through with your debugger to see what is happening?

Re: POPUP3 not working [message #7570 is a reply to message #7569] Mon, 25 January 2021 10:42 Go to previous messageGo to next message
htManager is currently offline  htManager
Messages: 339
Registered: May 2014
Senior Member
I stepped through the code after pressing as well the choose as the choose null button but I don't know where exactly I shall look for. In my _cm functions I cannot see an error. Can you tell me in which functions the chosen value should be visible that I can track it until there?

[Updated on: Mon, 25 January 2021 10:43]

Report message to a moderator

Re: POPUP3 not working [message #7571 is a reply to message #7570] Tue, 26 January 2021 04:12 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2272
Registered: April 2006
Location: Surrey, UK
Senior Member
After pressing the CHOOSE button in a popup form the calling script is reactivated, and it should call the popupReturn() method which in turn should call the _cm_popupReturn() method.

Rather than trying to look in a particular place you need to activate your debugger and step through the execution of the script line by line from the very start until you see where and why it jumps over the call to _cm_popupReturn().


Re: POPUP3 not working [message #7572 is a reply to message #7571] Tue, 26 January 2021 10:31 Go to previous message
htManager is currently offline  htManager
Messages: 339
Registered: May 2014
Senior Member
I found my fault. I forgot the key values in the $this->sql_select statement in the _read_CTE_default method in the tree class.inc. The tree structure was displayed properly without these pkey fields.
Now it works fine just as you said.
Previous Topic: Tree structure
Next Topic: Output 3 - _cm_output_multi()
Goto Forum:
  


Current Time: Tue Oct 19 07:32:18 EDT 2021

Total time taken to generate the page: 0.01114 seconds