Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE development » Framework » DEL1 - Exception
DEL1 - Exception [message #7716] Fri, 22 April 2022 05:58 Go to next message
htManager is currently offline  htManager
Messages: 373
Registered: May 2014
Senior Member
Hi Tony,

I have a strange behavior in one of my del1 pattern. There is always an exception saying that there is a unknown database. I attached the errorlog.htm. I checked the tables in dict (dict_table, dict_table_key, dict_column, dict_related_column). The fields, the relationships and the key are fine. It is just this pattern of this table. I used to have this behavior and after I exported the tables in php again, everything worked fine again.

Have you any idea where I can look for my fault?
Re: DEL1 - Exception [message #7717 is a reply to message #7716] Sat, 23 April 2022 05:11 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2303
Registered: April 2006
Location: Surrey, UK
Senior Member
Does this error with the DEL1 pattern only occur with this one table?

Can you send me the class.inc and dict.inc files for this table so that I can take a look?

The table class has the value 'unknown' loaded into $this->dbname in the abstract class by default, but this SHOULD be replaced with a valid dbname in the class constructor when it sets values into $this->dbname and $this->tablename before it calls $this->getFieldSpec_original();

Can you check the class constructor to see if it is doing what it is supposed to do? Can you check that this constructor is being called?


Re: DEL1 - Exception [message #7718 is a reply to message #7717] Mon, 25 April 2022 04:31 Go to previous messageGo to next message
htManager is currently offline  htManager
Messages: 373
Registered: May 2014
Senior Member
Yes, this happens only with this table.

As far as I see, the class constructor is working fine and the $fieldspec will be loaded successfully. In the further course of the validation checks the tablename gets lost.

I attached the class and the dict file.
Re: DEL1 - Exception [message #7719 is a reply to message #7718] Mon, 25 April 2022 05:14 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2303
Registered: April 2006
Location: Surrey, UK
Senior Member
I cannot see anything in those scripts which would change the value in $this->dbname.

You will need to step through the code with your debugger to see where the contents of $this->dbname changes.


Re: DEL1 - Exception [message #7720 is a reply to message #7719] Tue, 26 April 2022 15:32 Go to previous messageGo to next message
htManager is currently offline  htManager
Messages: 373
Registered: May 2014
Senior Member
Thank you. I will do so.
Re: DEL1 - Exception [message #7727 is a reply to message #7720] Fri, 13 May 2022 05:23 Go to previous messageGo to next message
klintsmith is currently offline  klintsmith
Messages: 1
Registered: May 2022
Junior Member
Hello guys, searching the same info for my similar issue. Can someone help me?
Re: DEL1 - Exception [message #7728 is a reply to message #7727] Sat, 14 May 2022 05:19 Go to previous message
AJM is currently offline  AJM
Messages: 2303
Registered: April 2006
Location: Surrey, UK
Senior Member
What exactly is your issue? What are the details? Have you investigated using your debugger?

Previous Topic: List pattern - fields of joined tables disappear by reset
Next Topic: php 8.0 compatability?
Goto Forum:
  


Current Time: Tue Jun 28 15:37:23 EDT 2022

Total time taken to generate the page: 0.01585 seconds