Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE » RADICORE Installation Issues » Installation Issues
Installation Issues [message #797] Thu, 03 May 2007 07:59 Go to next message
Techie is currently offline  Techie
Messages: 8
Registered: May 2007
Location: Idnia
Junior Member
Hi,

I am trying to install in my system with an environment of Win XP, Apache 2.2.4, My Sql 5.0 and PHP 5.2.1.

I have installed PHP along with the extention of DOM and XSL.
I have created all the schema and data as recommended.
I have also renamed config.default.inc into config.inc.

But still I am not able to run it. When I try to run it it shows a blank page.

Please let me know if anything I have missed.

Looking forward to hear some help.

Regards

Za Gohu
Re: Installation Issues [message #798 is a reply to message #797] Thu, 03 May 2007 08:08 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
Have you got display_errors=ON and error_reporting=E_ALL in your PHP.INI file? Have you checked your error log? Have you changed CONFIG.INC to identify your database username and password?

If you have done all these and still get no output you will have to step through with your debugger to see where it is failing.


Re: Installation Issues [message #801 is a reply to message #798] Thu, 03 May 2007 13:07 Go to previous messageGo to next message
Techie is currently offline  Techie
Messages: 8
Registered: May 2007
Location: Idnia
Junior Member
Thanks for your reply. I have done all the recommended changes.

I am getting the following error.

Warning: require(include.general.inc) [function.require]: failed to open stream: No such file or directory in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\radicore\menu\logon.php on line 18

Fatal error: require() [function.require]: Failed opening required 'include.general.inc' (include_path='.;C:\php5\pear') in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\radicore\menu\logon.php on line 18

My htaccess.txt has the following information.

php_value default_charset "UTF-8"
php_value include_path ".;C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\radicore\includes;C:\Program Files\Apache Software Foundation\Apache2.2\include;"

Please let me know if I have missed out anything.


Regards
Za Gohu
Re: Installation Issues [message #802 is a reply to message #801] Thu, 03 May 2007 13:44 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
Even though you have set include_path in your htaccess file the error message is showing it as '.;C:\php5\pear', which means that you have not configured apache to deal with htaccess files as it says in the installation instructions.

On Windows you cannot create a file with an extension but no name, which is why I use htaccess.txt instead of (dot)htaccess. You must therefore amend your apache config file so that the 'AccessFileName' directive points to 'htaccess.txt'.


Re: Installation Issues [message #803 is a reply to message #797] Thu, 03 May 2007 14:53 Go to previous messageGo to next message
Techie is currently offline  Techie
Messages: 8
Registered: May 2007
Location: Idnia
Junior Member
Thanks for your reply again. I have done the changes in it.
Please find attached my httpd.txt. But still it is giving me error.

Appreciate your help.

Regards
Za Gohu
  • Attachment: httpd.conf
    (Size: 18.85KB, Downloaded 1064 times)
Re: Installation Issues [message #804 is a reply to message #803] Thu, 03 May 2007 15:54 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
Did you restart apache after changing httpd.conf?

Re: Installation Issues [message #805 is a reply to message #804] Thu, 03 May 2007 18:23 Go to previous messageGo to next message
Techie is currently offline  Techie
Messages: 8
Registered: May 2007
Location: Idnia
Junior Member
Yes I did restart. No change. It throws the same error.

What could be wrong?

Regards
Za Gohu
Re: Installation Issues [message #806 is a reply to message #805] Thu, 03 May 2007 18:59 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
Your htaccess file is not being processed, which means your amendments to include_path are not being processed, which means that the include statement is failing to locate the specified file. You need to double check your apache configuration and the htaccess.txt file.

Your httpd.conf file appears to have the following line commented out:

AllowOverride All

Perhaps that is your problem?


Re: Installation Issues [message #807 is a reply to message #806] Fri, 04 May 2007 15:50 Go to previous messageGo to next message
Techie is currently offline  Techie
Messages: 8
Registered: May 2007
Location: Idnia
Junior Member
I completely reinstalled everything and redid all the installation stuff. Now I am stuck with the following error.

Fatal error: Call to undefined method domdocument::createElement() in C:\Apache\htdocs\radicore\includes\include.xml.php5.inc on line 600

I have installed all the extension of PHP.

Regards
Za Gohu
Re: Installation Issues [message #808 is a reply to message #807] Fri, 04 May 2007 17:14 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
There is a conflict somewhere which is caused by a faulty installation. That is why I recommend that people have a fully functioning installation BEFORE they try to install Radicore. You will need to reinstall and try again.

Re: Installation Issues [message #809 is a reply to message #808] Mon, 07 May 2007 13:50 Go to previous messageGo to next message
Techie is currently offline  Techie
Messages: 8
Registered: May 2007
Location: Idnia
Junior Member
I have totally reinstalled and rechecked to make sure that everything is working fine. Now I am getting the following error in logon.php

Fatal error: Call to undefined method domdocument::createElement() in C:\Apache\htdocs\radicore\includes\include.xml.php5.inc on line 600

and logon csxslt

Fatal error: Call to undefined method domdocument::createProcessingInstruction() in C:\Apache\htdocs\radicore\includes\include.xml.php5.inc on line 853

Please advice me any changes to be made.

Regards
Za Gohu
Re: Installation Issues [message #810 is a reply to message #809] Mon, 07 May 2007 15:48 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
If you are using an all-in-one installation package for Apache, PHP and MySQL I suggest you throw it away and install each piece manually as it is obviously giving you a corrupt installation. This is because they include both the XML and DOM XML functions at the same time, which is clearly wrong as they are incompatible.

If the DOM extension was installed properly you would not be getting an error message such as this. Try downloading and installing the latest PHP version from php.net (the zip version, not the installer version) and see if that makes a difference.


Re: Installation Issues [message #811 is a reply to message #797] Mon, 07 May 2007 19:36 Go to previous messageGo to next message
Techie is currently offline  Techie
Messages: 8
Registered: May 2007
Location: Idnia
Junior Member
I have reinstall php again with php zip file. Now I am getting the following error during logon in csxslt=off

This application has encountered an unrecoverable error
The following has been reported to the administrator:

2007-05-07 18:28:01
Fatal Error: XSL functions are not available. (# 256).

Error in line 1327 of file 'C:\WebServer\Apache2\htdocs\radicore\includes\include.xml.p hp5.inc'.

Script: /radicore/menu/logon.php

Remote Address: 127.0.0.1

Request URI: /radicore/menu/logon.php?csxslt=off


and if i try to logon in csxslt=on

I am getting logon screen, but user-id: mgr and password: password is not allowing me to login.

Things I have done:

1. I have activated extensions php_domxml.dll and php_xsl.dll by removing ; from php.ini.

2. I have run the mnu_usr.sql in menu database after running menu-data.sql.

I have attached my errorlog.html.
Please let me know any other strings to check.


Regards
Za Gohu
  • Attachment: errorlog.htm
    (Size: 6.36KB, Downloaded 781 times)
Re: Installation Issues [message #812 is a reply to message #811] Tue, 08 May 2007 05:09 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
You have not read the installation instructions properly. PHP 5 requires the DOM extension, not the DOM XML extension. That is why you are getting the error message informing you that the XSL extension cannot be found.

The second error message in your log file says that task 'mnu_user(pswd)' cannot be found, but this is defined in the mnu-data.sql file so should have been loaded.


Re: Installation Issues [message #815 is a reply to message #812] Wed, 09 May 2007 17:24 Go to previous messageGo to next message
Techie is currently offline  Techie
Messages: 8
Registered: May 2007
Location: Idnia
Junior Member
I am still struck with the following errors,

Fatal error: Call to undefined method domdocument::createElement() in C:\WebServer\Apache2\htdocs\radicore\includes\include.xml.ph p5.inc on line 600

Fatal error: Call to undefined method domdocument::createProcessingInstruction() in C:\WebServer\Apache2\htdocs\radicore\includes\include.xml.ph p5.inc on line 853

I understand that is error is because of DOM and XSTL issue. I not able to figure out the how the extension of DOM and XSTL is activated.

I have also added the following extension for libxstl in php.ini.

extension=php_domxml.dll
extension=php_xsl.dll
--with-xsl=C:\webserver\php5\libxslt

It will be great help if you can guide me on this php issue.

Please find attached my phpinfo() page about my environment.

Regards
Za Gohu

  • Attachment: test.mht
    (Size: 61.93KB, Downloaded 1043 times)
Re: Installation Issues [message #816 is a reply to message #815] Wed, 09 May 2007 18:14 Go to previous message
AJM is currently offline  AJM
Messages: 2350
Registered: April 2006
Location: Surrey, UK
Senior Member
The DOM XML extension is for PHP 4 only. PHP 5 uses the DOM extension which is part of the core and therefore has no dll which can be referenced in the php.ini file.

Please follow the installation instructions and install the correct extensions for your version of PHP.


Previous Topic: Fails: require 'include.general.inc'
Next Topic: Error 1064 while listing dictionary tables
Goto Forum:
  


Current Time: Mon Jun 24 08:51:05 EDT 2024

Total time taken to generate the page: 0.01370 seconds