Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE » How To » Setting PK field to NOEDIT, but not NOSEARCH
Setting PK field to NOEDIT, but not NOSEARCH [message #4977] Wed, 02 September 2015 05:14 Go to next message
rafs is currently offline  rafs
Messages: 69
Registered: May 2015
Member
Another issue: I set the PK of a field to NOEDIT, but not NOSEARCH.
On the UPDATE form it is indeed NOEDIT, which is what I want, because it is auto-incrementing.
However, on the SEARCH page, the PK field is listed, but not editable.

[Updated on: Wed, 02 September 2015 05:25]

Report message to a moderator

Re: Setting PK field to NOEDIT, but not NOSEARCH [message #4982 is a reply to message #4977] Wed, 02 September 2015 09:07 Go to previous message
AJM is currently offline  AJM
Messages: 2246
Registered: April 2006
Location: Surrey, UK
Senior Member
This is correct behaviour. If the NOSEARCH option is not set then the field will not be automatically removed from the SEARCH screen. If the NOEDIT option is set then the field will always be non-editable, even in search screens. If you want to change this then you should put code in the _cm_changeConfig() method to remove the field's NOEDIT option when the current pattern is "SRCH" or $GLOBALS['mode'] == 'search'.

Previous Topic: Typo in #faq09
Next Topic: setting default values for created_date and updated_date
Goto Forum:
  


Current Time: Sun Jun 13 10:59:47 EDT 2021

Total time taken to generate the page: 0.00962 seconds