Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE » RADICORE Installation Issues » include path
include path [message #961] Wed, 18 July 2007 12:22 Go to next message
NIMA is currently offline  NIMA
Messages: 3
Registered: July 2007
Junior Member
my radicore root directory is in E:\

I have changed the include path in my htaccess.txt file to

php_value include_path ".;E:\radicore\includes\;"

do I have to change anything else so that the code can find the include files?

for the time being, I have had to hard-coded the include path for every instance of the call to require() function. (very stupid, I know!!!! Embarassed but I still don't know where else the value of include directory is read from.
Re: include path [message #962 is a reply to message #961] Wed, 18 July 2007 12:47 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2352
Registered: April 2006
Location: Surrey, UK
Senior Member
The include_path is initially defined in your PHP.INI file, but can also be modified using the correct instruction in an htaccess file (if you are using Apache). It can also be modified using the ini_set() function in your PHP code.

In order to check that the htaccess file is being properly processed you need to run the phpinfo() function. Simply create a script called 'phpinfo.php' with the following contents
<?php phpinfo(); ?>
, put in in your web root, then run it from your browser.

If the contents of the htaccess file are not being processed, perhaps you have not configured Apache to deal with htaccess files. Details are provided in the installation instructions.


Re: include path [message #963 is a reply to message #962] Wed, 18 July 2007 14:21 Go to previous messageGo to next message
NIMA is currently offline  NIMA
Messages: 3
Registered: July 2007
Junior Member
I don't know where to look to find out if my xampp setup is handing htaccess.txt.

I ran the phpinfo. I am attaching the result. will you be able to tell if my httpd.conf is setup correctly.

my web root directory is drive e:
my xampp is installed on c:\xampp\
my radicore is installed on e:\radicore\

************************************************************ **
here is my httpd.conf content:
************************************************************ **

============================
handling root access to web:
============================

DocumentRoot "e:"
<Directory "E:/">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>

=====================
handling the htaccess
=====================

# this is for htaccess.txt used by radicore
AccessFileName htaccess.txt
<Files ~ "^htaccess\.">
Order allow,deny
Deny from all
</Files>

# this is for .httaccess used by other applications.
<FilesMatch "^\.ht">
Order allow,deny
Deny from all
</FilesMatch>

************************************************************ ***
My htaccess.txt content:
************************************************************ ***

<Files ~ "\.inc$">
Order deny,allow
Deny from all
</Files>

php_value default_charset "UTF-8"
php_value include_path ".;E:\radicore\includes\;c:\xampp\htdocs\radicore\includes\"

php_value register_globals 0
php_value magic_quotes_gpc 0
php_value magic_quotes_runtime 0
php_value magic_quotes_sybase 0
php_value session.use_cookies 1
php_value session.use_only_cookies 0
php_value session.use_trans_sid 1
php_value session.gc_maxlifetime 3600
php_value arg_separator.output "&amp;"
php_value url_rewriter.tags "a=href,area=href,frame=src,input=src,fieldset="

Re: include path [message #964 is a reply to message #963] Wed, 18 July 2007 14:47 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2352
Registered: April 2006
Location: Surrey, UK
Senior Member
When you look at the output from phpinfo() it should be a simple matter to search for 'include_path' to see what it says. The output you supplied clearly shows that the contents of your htaccess file is not being processed.

I suggest you stop trying to configure Apache to deal with htaccess files and modify the include_path parameter directly in your PHP.INI file.



Re: include path [message #965 is a reply to message #964] Wed, 18 July 2007 15:17 Go to previous message
NIMA is currently offline  NIMA
Messages: 3
Registered: July 2007
Junior Member
thanks AJM!!

I finally managed to find the problem. there where multiple instances of php.ini.

I was always changing the one in the \php direcory. whereas, php was reading php.ini from the \apache directory.

problem fixed. thanks again.
Previous Topic: Path information
Next Topic: Error while creating menu database in 1.26
Goto Forum:
  


Current Time: Mon Jul 15 20:04:33 EDT 2024

Total time taken to generate the page: 0.00941 seconds