Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE » RADICORE Installation Issues » Help ! Can not log In Radicore v1.76.0 (Keep getting - You must log in to access this system)
Help ! Can not log In Radicore v1.76.0 [message #3193] Thu, 13 December 2012 18:18 Go to next message
eazl is currently offline  eazl
Messages: 1
Registered: December 2012
Junior Member
Hi, I am new to radicore and followed the instructions to install.

I am using php 5.2.17 on Centos 5.8, mysql v 5.0.77

I started by creating the databases

create database connects_menu;
create database connects_dict;
create database connects_audit;
create database connects_workflow;
create database connects_survey;

created the schema
mysql -u root -p connects_menu < menu/sql/mysql/menu-schema.sql
mysql -u root -p connects_dict < dict/sql/mysql/dict-schema.sql
mysql -u root -p connects_audit < audit/sql/mysql/audit-schema.sql
mysql -u root -p connects_workflow < workflow/sql/mysql/workflow-schema.sql
mysql -u root -p connects_survey < survey/sql/mysql/survey-schema.sql

loaded the data

mysql -u root -p connects_menu < menu/sql/mysql/menu-data.sql
mysql -u root -p connects_dict < dict/sql/mysql/dict-data.sql
mysql -u root -p connects_workflow < workflow/sql/mysql/workflow-data.sql
mysql -u root -p connects_survey < survey/sql/mysql/survey-data.sql

# load menu users (once)
mysql -u root -p connects_menu < menu/sql/mysql/mnu-user.sql


checked in database all the tables are created and there is data in them

renamed the htacess .htaccess and pointed it to the include location

<Files ~ "\.inc$">
Order Deny,Allow
Deny from all
</Files>

php_value include_path "/opt/test/radicore/includes"

php_value default_charset "UTF-8"
php_value mbstring.internal_encoding "UTF-8"

php_value register_globals 0
php_value magic_quotes_gpc 0
php_value magic_quotes_runtime 0
php_value magic_quotes_sybase 0
php_value session.use_cookies 1
php_value session.use_only_cookies 1
php_value session.use_trans_sid 0
php_value session.gc_maxlifetime 14400
php_value arg_separator.output "&amp;"
php_value url_rewriter.tags "a=href,area=href,frame=src,input=src,fieldset="
php_value always_populate_raw_post_data 1

php_value error_log phperror.log

create the includes/config.inc with user/pass/database/host

i got an error about timezone, so I added i the file
date_default_timezone_set('America/Los_Angeles');

and defined the prefix as such

$GLOBALS['dbprefix'] = 'connects_';

I got the login screen. I used the MGR/password and did not go anywhere

first time i fill the info, no feedback is given, but I can see the following cookie in firebug (changed domain with XXX below)

logon_screen_menu0=%2Fmenu%2Flogon.php; path=/; domain=XXX
menu0=fov5a0ajdf2t23q5inect6uu54; path=/; domain=XXX

I do a select of the php_session table in connects_audit and I see
mysql> select * from php_session\G
*************************** 1. row ***************************
session_id: fov5a0ajdf2t23q5inect6uu54
user_id: UNKNOWN
date_created: 2012-12-13 15:15:05
last_updated: 2012-12-13 15:15:05
session_data: cookie_data|a:1:{s:18:"logon_screen_menu0";s:15:"/menu/logon.php ";}log_sql_query|b:0;timezone_server|s:19:"America/Los_Angeles ";XSLT_client_side|b:0;css_file|s:11:"default.css";default_language|s:2: "en";user_language_array|a:2:{i:0;a:4:{i:0;s:5:"en-us";i:1;s:2: "en";i:2;s:31:"English (United States) [en_US]";i:3;s:7:"English";}i:1;a:4:{i:0;s:2:"en";i:1;s:2: "en";i:2;s:12:"English [en]";i:3;s:7:"English";}}supported_languages|a:1:{s:2:"en ";s:2:"EN";}user_language|s:2:"en";log_xml_document|b:0;pages|a:1:{s:15: "/menu/logon.php";a:4:{s:7:"task_id";s:5:"logon";s:10:"task_array ";a:1:{s:5:"logon";b:1;}s:5:"logon";a:1:{s:12:"script_count ";i:1;}s:10:"pattern_id";s:5:"logon";}}rowsperpage|i:10;page_stack|a:0:{}
1 row in set (0.00 sec)


I try again and I see the same information in firebug, but in addition I get a message in green 'You must log in to access this system.'

logon_screen_menu0=%2Fmenu%2Flogon.php; path=/; domain=XXX
menu0=fov5a0ajdf2t23q5inect6uu54; path=/; domain=XXX

I do a select * from php_session; form the connects_audit table and it comes up empty

Any help would be appreciated to debug this.

Re: Help ! Can not log In Radicore v1.76.0 [message #3194 is a reply to message #3193] Fri, 14 December 2012 02:13 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2272
Registered: April 2006
Location: Surrey, UK
Senior Member
This tells that the first pass of the logon screen is creating a session_id as it is being written to the database. After pressing SUBMIT on the logon screen the input data is validated and values are set in the $_SESSION array to show that the logon has been successful. The next page will look in the $_SESSION array, and if the logon data is not there it will automatically send you back to the logon screen with the message "You must log in to access this system". The fact that you are getting this message means that the post-logon process is not reading the $_SESSION data. I had a similar situation recently, and I tracked it down to the fact that my browser settings disallowed all cookies, even temporary cookies, for that domain. This meant that the session_id created in the logon process was not being passed to the post-logon process, which in turn meant that it could not read the session data associatewd with that session_id. I changed my browser settings and the problem was solved.

icon7.gif  Re: Help ! Can not log In Radicore v1.76.0 [message #3344 is a reply to message #3194] Sat, 19 January 2013 04:59 Go to previous message
zyzzyva is currently offline  zyzzyva
Messages: 1
Registered: January 2013
Junior Member
i got the problem too.
i got an error about timezone,but when i set php.ini
date.timezone =
it is OK now.
maybe your timezone setup would match ur system's timezone.
Previous Topic: Partial Installation it seems
Next Topic: MySQL error on Generate PHP
Goto Forum:
  


Current Time: Sat Oct 16 12:06:25 EDT 2021

Total time taken to generate the page: 0.00913 seconds