Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE » RADICORE Installation Issues » multibyte error (Fatal error when inserting non-latin characters)
multibyte error [message #7100] Mon, 11 December 2017 06:54 Go to previous message
barnabooth is currently offline  barnabooth
Messages: 12
Registered: February 2011
Junior Member
I have been trying to figure out the following problem for several days now, but I am afraid I can't come any further than this. The problem is:

When I try to insert non-latin characters I get the following error message:

Fatal Error: MySQL: Incorrect string value: '\xD0\xAD\xD0\xB2\xD0\xB5...' for column 'new_value' at row 1 (# 256)
Error in line 1192 of file '/var/www/html/radicore/includes/dml.mysqli.class.inc' ...

As far as I understand this is a multibyte-error.

My database (mariaDB) is entirely set in utf8mb4_unicode_ci and when I access my db from phpMyAdmin for instance, I have no problem inserting non-latin characters. This -- I think -- excludes any issues with server or php.ini settings, and instead points to my radicore-setup. (And when they are inserted through phpMyAdmin they also shows up correctly in radicore).

The problem appeared after a reinstallation when I shifted from apache2 to FPM/FastCGI
Before I had php_value settings for utf8 in the .htaccess file, which is not possible with FPM. Instead I have tried to include

default_charset = "UTF-8"
mbstring.internal_encoding "UTF-8"

in a .user.ini file at radicore-root and my application root (also tried with "utf8mb4" without any success).

Is it possible that you (or someone else) could point me at the right direction where to look for a solution of this problem?
 
Read Message
Read Message
Read Message
Read Message
Previous Topic: Installation 2.0.7
Next Topic: XSL-Function error
Goto Forum:
  


Current Time: Sun May 22 15:27:28 EDT 2022

Total time taken to generate the page: 0.01741 seconds